Updates to index.html on front-end not rendering

I am working on a client front-end on my MacBook. I made a change to ./devstack/frontend/src/assets/index.html, but always get the same result when I refresh the page. I think this might be related to this issue. I tried this solution but it made no difference.

No matter what I do to mangle index.html (for troubleshooting), the front-end keeps serving the pristine version, as if it’s serving it from a cache that it won’t update. index.html contains the div where React gets mounted, so I wouldn’t expect that to be included in the bundle. It’s the one thing I would expect to load first, so I should see any change immediately.

Does anyone have any insight? I am stuck now.

Looks like you found a solution at https://tasks.opencraft.com/browse/FAL-1659 , great.

I can’t reach JIRA now. It returns 404. But yeah, I found make watch-file and then changes I made in the editor got rebuilt inside the Docker container. This is definitely something we should warn people with Macs.