What version of Python is compatible with edx/devstack?

I cloned edx/devstack to my laptop. Is there a known version of Python that it’s compatible with devstack? I looked for something in the README and in requirements/* but couldn’t find anything.

Can I just use the latest (3.9) for the virtual environment?


@lawrence Try 3.8. It’s what edX has standardized on for all its Independently Deployable Applications (IDAs).

1 Like

Thank you, @Fox. Do you think that this should go in the README somewhere, or do you think it will change soon? Of course, it’s an EdX project, so a change to a README would require a new Issue and PR to them and I’m not sure that’s worth the effort right now. Hopefully, people will find your previous response here.

@lawrence If it’s not in the README, then yes we probably should create a task for adding it. There is a portion of your budget that will be allocated later for fixing documentation issues you found during your trial.

Also if these items are preventing you from starting work (I noticed another thread about hardware requirements) feel free to ask them in Mattermost in the appropriate channel (in the case of those two threads, the Devstack channel should do.)

Thank you, @fox. None of those issues are preventing me from setting up my environment so far. I may have to keep an eye on the Docker resources requirements, but so far, I’ve been able to make progress.

1 Like

@lawrence it shouldn’t be a problem because the python versions are handled by docker itself.

Just FYI, the latest official openedX supports 3.8

I still had to specify the Python version when I ran “virtualenv -p /path/to/python”. When I tried python 3.9, some of the make targets failed horribly. For example, it couldn’t build “crypto” and other dependencies.

The docker containers have their own Python environments. Just saying… No further action needed. :slight_smile: